Sua gem funciona bem com JRuby?

Acabei de ler no post Notícias do Front #5 do Fábio Akita uma notícias que me deixou muito feliz:

is it jruby? – recentemente a Brightbox lançou o site is it ruby 1.9?, onde a comunidade poderia testar gems e dizer nesse site se ela é ou não compatível, em seus testes, com o ruby 1.9. Agora foi lançado mais uma com o mesmo objetivo mas desta vez para avaliar a compatibilidade de gems com o jruby. Mais e mais a comunidade está se conscientizando que as gems precisam receber mais tratamento para ficarem compatíveis com múltiplas virtual machines. Isso é muito bom e espero que todos colaborem.

Isto porque sou usuário de JRuby e volta e meia tenho problema com alguma gem que não funciona com ele, por conta de extensões nativas em C.

Então, por caridade, quando fizer uma gem, veja se ela funciona bem com JRuby também. :)

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>